Project

General

Profile

int2lm and ERA5

Added by Jennifer Brauch 8 months ago

Hello,

I wanted to run CCLM with ERA5 Input. So I got the cas files from Mistral, and changed the settings for int2lm accordingly, but I got an error message, which I cannot place. Do I have to tell int2lm somwhere, that I use cas files instead of caf files?

I will paste the error message below. The int2lm version I am using is int2lm_131101_2.00_clm4.

Any help is highly appreciated!

Jenny

Output:
----- start INT2CLM
SETUP OF INT2LM
INITIALIZATIONS
Info about KIND-parameters: iintegers / MPI_INT = 4
1275069467
int_ga / MPI_INT = 4
1275069467
INPUT OF THE NAMELISTS * NOTE: Old 10 digit date format is used for output files of INT2LM
WARNING
Cressman interpolation not compatible with this version ** * l_cressman is reset to .FALSE. * * specifications of input soil main levels * * from Namelist INPUT are used * * specifications of LM soil main levels * * from Namelist INPUT are used * *** A default set for vcoord parameters is used: 1 *** A default set for refatm parameters is used: 2
GRID ORGANIZATION
Decompose COSMO-Model
Decompose climate grid
[...]

------------------------------------------------------------
  • PROGRAM TERMINATED BECAUSE OF ERRORS DETECTED
  • IN ROUTINE: int2lm_org *
  • ERROR CODE is 2222
  • ERROR * Climate grid decomposition failed
    *----------------------------------------------------------

    forrtl: error (76): Abort trap Signal

Int2lm settings:
&GRID_IN
!pcontrol_fi =30000.,
ie_in_tot = 544,
je_in_tot = 224,
ke_in_tot = 97,
startlat_in_tot = 19.25058,
startlon_in_tot = -68.90625,
endlat_in_tot = 81.92025,
endlon_in_tot = 83.8125,
pollat_in = 90.0,
pollon_in = 180.0,
lushift_in=.FALSE.,.FALSE.,
lvshift_in=.FALSE.,.FALSE.,
ke_soil_in=3,
czml_soil_in=0.035, 0.175, 0.64, 1.775,
/END


Replies (1)

RE: int2lm and ERA5 - Added by Burkhardt Rockel 8 months ago

The chosen COSMO-CLM domain is too big for the European ERA5 cas files.
The error comes from module src_decomposition.f90

  ! Check whether coarse grid is big enough
  IF (zminlat < latitudes_in(1+nzbounds_s) .OR.             &
      zminlat < slatitudes_in(1+nzbounds_s)) THEN
    ierror  = 2
    yerrmsg = 'Coarse domain is not big enough'
    PRINT *, 'zminlat ', zminlat, ' < ', & 
      MAX(latitudes_in(1+nzbounds_s), slatitudes_in(1+nzbounds_s))
  ENDIF

the ierr = 2 gives the ERROR CODE 2222 in the output.

and should be listed in the log file. However, the crash may have occurred before the program had flashed out the output. It seems that the problem is at least with the southern bound of the domain.

    (1-1/1)