Project

General

Profile

INT2LM in routine vert_interpol

Added by Cecille Villanueva-Birriel over 3 years ago

I am getting an error while downscaling MPI-ESM-LR data from the dkrz tape archive. I am using int2lm2.0_clm4. I am running a 30 year simulation and the downscaling worked for all years except for two (1987 and 1989). The error while opening a file in 1987, for example, is the following

@/SCRATCH/acad/cclm/MPI-ESM-LR/historical/year1987/caf1987080318.nc
CLOSING ncdf FILE * Control Geopotential has been calculated * * FI is marked as being read *
NTAU = -63 17: MUST BE GREATER THAN 4 ** ERROR in tautsp2D: while processing j-index: 1
*----------------------------------------------------------
* PROGRAM TERMINATED BECAUSE OF ERRORS DETECTED * IN ROUTINE: vert_interpol * * ERROR CODE is 2 * Error in tautsp
------------------------------------------------------------
NTAU = -63 17: MUST BE GREATER THAN 4 *** ERROR in tautsp2D: while processing j-index: 1

I have attached the log files, header of the files where I got the error, INPUT, and OUTPUT files for both years.

I am not sure if it is related to a parameter from the model or something in the data that is giving me this error. Any information will be greatly appreciated. Thanks in advance.

Cecille


Replies (1)

RE: INT2LM in routine vert_interpol - Added by Burkhardt Rockel over 3 years ago

I guess that there are some unrealistic values in the files
/SCRATCH/acad/cclm/MPI-ESM-LR/historical/year1987/caf1987080318.nc
/SCRATCH/acad/cclm/MPI-ESM-LR/historical/year1989/caf1989081612.nc
However, several colleagues from the CLM-Community already used the data without any problem.
Have you checked the data files by using ncview or/and cdo info or/and setting the idbg_level in the namelist to a high value (which gives more information in the log file. It is better to run int2lm for the idbg_level test with nprocx = 1, nprocy = 1 for the test to get a cleaner logfile)?

    (1-1/1)