Project

General

Profile

Missing constant T_S output in int2lm_131101_2.00_clm4 runing with IFS forcing data

Added by Sebastian Helgert about 6 years ago

Dear all,
I have installed the Starter Package cclm-sp_2.1 and ran the in int2lm_131101_2.00_clm4 with IFS-forcing data (3 months simulation). The int2lm run was fine, but in the CCLM simulation (cosmo_131108_5.00_clm8) I got an error (see attachment Job_ic2_490997). I found out, that in the Int2lm output the constant soil surface temperature (T_S) is missing. I have worked with IFS forcing data in the COSMO-NWP mode before. So I tested Int2lm with same settings with the starter packages int2lm_131101_2.00_clm4(attachment: run_cclm_int_0_44Grad) and the int2lm from COSMO 5.01 model (int2lm_141125_2.01) in the climate mode (lbdclim = .TRUE , run_int2_0_44Grad_NWP). In the latter simulation I got an T_S and then also the CCLM simulation (cosmo_131108_5.00_clm8) works. Therefore I think there is no problem with the forcing data. Could it be, that there is a wrong translation/reading in the source code (int2lm_131101_2.00_clm4) of IFS data or grib_api data? I did some further test with GME data(grib format) with the starter packages int2lm_131101_2.00_clm4 and there I got a constant T_S output. Can I use the original COSMO int2lm_141125_2.01 (with lbdclim = .TRUE. ) to run the CCLM simulation (cosmo_131108_5.00_clm8, attchment: run_cclm_0_44Grad)? Or is there an important different between int2lm_141125_2.01(COSMO model) and the COSMO-CLM int2lm_131101_2.00_clm4?
Thanks in advance!

Best regards

Sebastian Helgert


Replies (1)

RE: Missing constant T_S output in int2lm_131101_2.00_clm4 runing with IFS forcing data - Added by Burkhardt Rockel about 6 years ago

Mixing NWP and RCM mode is always a bit tricky, since this has not been fully tested. As far as I know the GRIB API was newly introduced in INT2LM2.00 for the NWP. Therefore there may be still some bugs when combining it with the RCM setting lbdclim=.TRUE. For instance: the T_SO and W_SO in GRIB are read/write in the dimensions are different: 0:ke_soil_in+1 (T_SO) and 1:ke_soil_in+1 (W_SO). In netCDF the dimensions for the soil quantities have to be the same (both are 1:ke_soil_in+1). The “0” index of T_SO in netCDF is written to and from T_S. This means T_S exists only in the reading/writing process of netCDF. Maybe this was not taken into account for the GRIB API read to netCDF write in INT2LM2.00.
If INT2LM2.01 works for you, please go for that version.

    (1-1/1)